제목에서 말한거 같이

이번에 sql서버를 교체를 하는데 

지금 저희가 사용하고 있는 jdbc 버전이 4 입니다.


ms sql 사이트에 들어가서 버전별 호환하는걸 알아보니 sql 2016까지만 호환이 된다는 문서가 있어서요..

혹시나 제가 확인하지 못한게 있을까 싶어 여기에 질문 올립니다.


jdbc 버전은 4

jdk1.6.0_38 인 상황에서 가장 높은 버전의 sql server 버전은 어떻게 될까요..


회사에서는 아무래도 최신인 sql 2017이나 2019를 검토하고 있는거 같은데

최신버전이 아닌 그 밑의 버전을 구입하는것도 괜찮을까요???


자바 관련 개발자가 저밖에 없다보니 물어볼 곳이 여의치가 않습니다.


감사합니다.